Tips and Tricks/Support *

Can't upload image via Links tab
dpat57 at 7:13AM, March 13, 2022
(offline)
posts: 135
joined: 8-10-2009
In Edit Comic, I select Links tab and go through the steps, filling in the fields and selecting type: “other images” and then the .jpg to be uploaded. But when I select “add” the image doesn't upload and the fields blank out.

“Any image links uploaded will be reduced to 150px max width” – that's okay, the image is 150px width. And I've done this before, many times. This same blip has occurred in 4 different comics now. I think it's the software that's suddenly* decided to not work rather than pilot error.

Any thoughts appreciated!

* when I say “suddenly” said blip could have happened at any time during the past 6 months, I took a break, updates have just started again. But I remember my update process! Comic pages are going up okay, it's just the links images that won't upload.
Ozoneocean at 10:54AM, March 13, 2022
(online)
posts: 28,061
joined: 1-2-2004
Weird. I'll need to investigate it.
 
dpat57 at 1:44PM, March 13, 2022
(offline)
posts: 135
joined: 8-10-2009
It's not a show-stopper, I was really asking in case you knew of something that had stopped or broken, if no one else has mentioned this then que sera, don't waste any time on it!
Ozoneocean at 7:47AM, March 14, 2022
(online)
posts: 28,061
joined: 1-2-2004
I tested it and it worked every time for me:
https://www.theduckwebcomics.com/WILDFIRE/

Could it be a browser issue? I was using a Firefox based browser.
Maybe your computer ran out of memory? Try closing some tabs?

I wonder what the issue was…
 
dpat57 at 11:51AM, March 14, 2022
(offline)
posts: 135
joined: 8-10-2009
Thanks for looking at this. Damn, it would have been easier if it hadn't worked for you. :)

I'm using Firefox and I never have loads of tabs open. I made sure to have nothing else running either, guzzling up memory.

I just updated one of my comics, Crowbar, the comic page uploaded fine, so on to the Edit Comic > “links” tab…

Here's how it looked, with the previous image I'd uploaded still there:




I wanted to replace this, so I selected the X to delete the old image, and confirmed OK:




I filled in the fields, title, URL, type: “other comics” and selected the new image to be uploaded:




But after I selected the “add” button… no “other comics” image was uploaded.




The image I was trying to upload is this:

https://s3.amazonaws.com/media.drunkduck.com/users/dpat57/assets/latest_update_v_g3NXO3g.jpg

…which is no different size-wise than the old image I deleted.


last edited on March 14, 2022 1:02PM
Ozoneocean at 5:59PM, March 14, 2022
(online)
posts: 28,061
joined: 1-2-2004
This is very strange… hmmm… Will need more looking into
 
Ozoneocean at 9:24PM, March 14, 2022
(online)
posts: 28,061
joined: 1-2-2004
Ahhhh, OK
I solved it haha!

you got your slashes the wrong way around in your link address.

It should be:
http://mywebcomics.org

Not:
http:\\mywebcomics.org

Unfortunately we don't have an error message for that. It just fails to work when invalid data is processed :(
 
Ozoneocean at 9:26PM, March 14, 2022
(online)
posts: 28,061
joined: 1-2-2004
Thank goodness you posted a screenshot! There's no way I would have been able to work that out otherwise XD
 
dpat57 at 1:43AM, March 15, 2022
(offline)
posts: 135
joined: 8-10-2009
Thank you! Amazing detective work.

I am infuriated this was the cause! (lol) You know how you can double-click a data field to list previous items that were entered into that field, to easily select them again? That's what I was doing – selecting the mywebcomics.org URL from that list, and not noticing the slashes were the wrong way \\ round. But there was no right way // round item, despite the fact it must have been entered dozens or maybe even hundreds of times before. And it's extremely unlikely to the point of impossibility that I would ever have entered slashes the wrong way round. My fingers know what goes after http: dammit.

Apologies for this faux pas! Thanks for your time.
Ozoneocean at 3:27AM, March 15, 2022
(online)
posts: 28,061
joined: 1-2-2004
No worries! I'm glad we could come to the bottom of it :D
 

Forgot Password
©2011 WOWIO, Inc. All Rights Reserved Google+