Tips and Tricks/Support

Hippie Van's Grand List of Bugs (and Workarounds!)
HippieVan at 4:14PM, Oct. 9, 2014
(online)
posts: 3,003
joined: 3-15-2008
I've compiled a list of common bugs and other issues on DD below. If you encounter a problem that isn't on this list, please post in this thread and it will be added along with any resolutions that we can figure out!

PLEASE READ THE WHOLE LIST BEFORE POSTING.

NOTE: Some of these workarounds require contacting an admin to fix the issue. Our current contact details are as follows.
ozoneocean - ozoneocean (at) yahoo (dot) com
kawaiidaigakusei - kawaiidaigakusei (at) gmail (dot) com; or via PQ
HippieVan - hippievannews (at) gmail (dot) com; or via PQ
You may also send a private message to our Facebook page.




Custom navigation arrows aren't showing up
Open layout mode and edit the image links. Take out the "http://“ and replace it with ”https://s3.amazonaws.com/“ at the beginning of the image links.
You also need to delete all the random letters and numbers that appear after the ”.png“/”.jpg" portion of the filename.

When I upload new pages, old pages are replaced with the new one/my comic suddenly has duplicate pages.
This happens when you don’t give the image files for your pages unique names. So if you upload a new page called “page5.jpg” and you have an older page with the same name, the old one will be replaced with the new page.

I updated my comic, but it's not showing up in “Latest Updates”
Unfortunately, this currently happens when a comic page is uploaded in advance. The only fix at this point is to update your comic on the day you want the page to appear.

I've updated my comic, but the date in the control panel is not accurate.
We can manually change the date to the correct one (send an admin a PQ), but this won't fix the problem permanently. This may also be the result of pre-uploading comic pages.

The PQ Inbox lists every single message ever sent on one page
Unless it is imperative to keep every single PQ ever received, it is a good idea to organize/handle the number of PQs you have.

Changes made to in layout mode (e.g. background colour) won't save
If you have an ad blocker activated, try deactivating it and reloading the page before trying again. (Note: I've only seen one instance of this fix being used. Please let me know if this works/does not work for you.)

I'm seeing inappropriate ads
If this happens, please take screenshots if possible and send them to us so we can deal with it. Ads on the site should not show nudity, excessive violence or other adult content.

Comic pages from 2010 aren't showing up.
This is due to a massive crash in that year. Pages for a period of a few months (something like Jan-March, I believe) before the crash weren't part of the backup so they couldn't be restored when the site was up and running again. People had to re-upload saved copies.

The site is excessively slow and/or hangs instead of loading.
Please contact one of the admins by email! We can reset the server and get everything chugging along again.

I deleted my comic and now I want to create a new comic with the same name, but it says the name is already taken.
Contact an admin. In future, please think carefully before deleting your comic.

My comic doesn't show up in searches.
Contact an admin.
Admins: last time this happened, the comic had “date modified” set to “(None)” in the admin panel. Just add a date and the comic will appear in searches.

I am unable to access Adult comics.
If the date of birth that you entered when you signed up has you as younger than 18, you will be unable to access adult-rated comics. If you entered your birth date incorrectly, message an admin and we can fix it.
Note: It seems that sometimes users are unable to change the year of birth when registering. If this happens to you, message an admin with your correct birth date and we can change it for you.

My comic page won't upload!
If you get the error “413 Request Entity Too Large,” the image you're trying to upload is too large. Image files must be under 1 mb. You can use online programs such as Sumo Paint to compress and resize images.
If your image is not over 1 mb, post below or message an admin and we'll try to figure out the problem.

File limits are temporarily disabled, but please try to keep your comic images to a reasonable size.

The Password Reset button doesn't work
Please send an email to ozoneocean or another admin with your DD account name and the email address you used to sign up for it, and we can reset it for you.
Fixed! :O

Stats don't work!
Yep. :( Sorry. This is definitely one of the first things on the to-do list if/when we can fix some things on the site.

FIXED! :D

I don't get a notification when I have a new Personal Quack (PQ)!
This one unfortunately isn't a bug so much as a misguided “feature” from the site's big redesign. Just try to check PQs frequently to avoid missing them.

FIXED!

Multiple quotes don't work in forum posts/editing my post messed up the quotes.
The easiest thing to do is go into html editing and do something like: {quote}{b}Hippie Van{/b}said: {/quote}
Replace {} with square brackets
html editing is the also easiest way to make any edits to a comment without having your formatting jumbled up. Unfortunately, the html editor is not available when using a tablet/smartphone.

FIXED!

The forums text editor doesn't keep line breaks.
Type a space into the blank line.

FIXED!

Adding links to comics through “Manage Links” turns up an Internal Server Error
Please contact one of your friendly admins via PQ or email and we can add links through the admin section of the site! What we need:
Your banner (max 150px wide for a side panel)
The URL
Whether you want it as a header or a side panel
Alternatively, links may always be added to author notes if you don't want to wait for us.

FIXED!
Duchess of Friday Newsposts and the holy Top Ten
last edited on Feb. 14, 2016 5:57PM
ozoneocean at 7:26PM, Oct. 28, 2014
(online)
posts: 26,540
joined: 1-2-2004
This is really an amazing list.
The original locked bug thread isn't sticky anymorre. So here's a link: http://www.theduckwebcomics.com/forum/topic/169969/
 
irrevenant at 4:21PM, Sept. 19, 2015
(online)
posts: 753
joined: 1-13-2007
I've just noticed that, if you search for The Duck Webcomics on Google,  the site description is a dump of page content rather than aa useful description of the site. 
For example, at the moment the Google results for The Duck say:
The Duck Webcomics


theduckwebcomics.com/
Stagnant Waters Shounen Ai Webcomic … Mindmistress at Drunk Duck …. A 300 + page silver age superhero comic! http://bit.ly/lHkv0W #drunkduck #webcomics.
HippieVan at 10:35AM, Sept. 20, 2015
(online)
posts: 3,003
joined: 3-15-2008
Hmmm. I'll ask Oz/JNP if they know how to fix that! Thanks!
Duchess of Friday Newsposts and the holy Top Ten
last edited on Sept. 20, 2015 10:36AM
Nywoe at 6:33PM, Nov. 1, 2015
(online)
posts: 3
joined: 11-1-2015
I just joined the site and it says I've been a member since November 11, 2015, which is impressive because that is 10 days from now.  WAIT IS THIS A TIME TRAVEL SITE?!
HippieVan at 7:37PM, Nov. 1, 2015
(online)
posts: 3,003
joined: 3-15-2008
Looks like November 1st to me! Where are you seeing November 11th?
 
Duchess of Friday Newsposts and the holy Top Ten
smbhax at 1:09AM, Feb. 3, 2016
(online)
posts: 65
joined: 6-14-2009
With the new round of updates, the ability to pop up a window into which you could enter HTML when writing your Author's Note seems to have disappeared.

This was an important feature for advanced formatting–as well as for those of us who cross-post our comic blogs, since two of the other *cough* main comic hosting sites allow pasting in a chunk of HTML for the author comment.

Was this feature removed intentionally, or accidentally? Or was it just moved somewhere that I haven't spotted? : o
Stellar at 9:36AM, Feb. 4, 2016
(online)
posts: 31
joined: 11-25-2007
My first upload since the updates to the site have been made isn't going too well. I get this error; 413 Request Entity Too Large.
The page is saved in my standard format as a png file, 900x1350px and is 1.22 mbs. Any clarification on what's wrong would be much appreciated! (=

Edit; After some playing around uploading different proportioned images and different sized images it seems the problem is that the page is over a mb in size? Please tell me that's an error. Like some previous pages in the chapter, most of the coming pages for Gate are over a mb due to the detail I've put into them.
last edited on Feb. 4, 2016 9:58AM
HippieVan at 1:29PM, Feb. 4, 2016
(online)
posts: 3,003
joined: 3-15-2008
Stellar wrote:
My first upload since the updates to the site have been made isn't going too well. I get this error; 413 Request Entity Too Large.
The page is saved in my standard format as a png file, 900x1350px and is 1.22 mbs. Any clarification on what's wrong would be much appreciated! (=

Edit; After some playing around uploading different proportioned images and different sized images it seems the problem is that the page is over a mb in size? Please tell me that's an error. Like some previous pages in the chapter, most of the coming pages for Gate are over a mb due to the detail I've put into them.

Yep, you've accurately identified the issue there! Uploads can't be more than 1MB (sorry!). Apparently this has always been true, but a bug was previously preventing it from actually being enforced. I think ozone is planning on adding a warning to the upload page.

We'll definitely take into account that you're finding it difficult to keep pages under 1mb, though.
Duchess of Friday Newsposts and the holy Top Ten
Prototype at 10:16AM, Feb. 7, 2016
(online)
posts: 40
joined: 5-23-2008
Yeah, I think the below 1MB limit is gonna be a problem for a lot of people. Most save their pages in PNG (especially CG comic creators like genejoke and Elcid) and that makes the files a bit over 1MB but it keeps all the right colors and quality of the pages, and they look as they should.

JPG compress the pages way too much, and it's no fun uploading pages that look muddy and washed out.
last edited on Feb. 7, 2016 10:53AM
Jennifer Roggeveen at 11:57AM, Feb. 7, 2016
(online)
posts: 7
joined: 8-8-2014
Hello, so I was attempting to upload my most resent pages when I got this message…

413 Request Entity Too Large
nginx/1.9.10

At fist I thought maybe my file size was too large but I have not changed my file sizes and I have never had an issue before but just to make sure I attempted to upload an older page that I already have on the site and I got the same message.

Anyone have any ideas?


EDIT: Sorry guys I have just been reading other peoples posts and see the issue, I will try changing my file size.

SECOND EDIT: I changed the file size and now it is working.
My previous file size was 1.75 MB. I didn't know!
last edited on Feb. 7, 2016 12:12PM
HippieVan at 12:32PM, Feb. 7, 2016
(online)
posts: 3,003
joined: 3-15-2008
@Jennifer: Glad you were able to figure out the problem! :)

Prototype wrote:
Yeah, I think the below 1MB limit is gonna be a problem for a lot of people. Most save their pages in PNG (especially CG comic creators like genejoke and Elcid) and that makes the files a bit over 1MB but it keeps all the right colors and quality of the pages, and they look as they should.

JPG compress the pages way too much, and it's no fun uploading pages that look muddy and washed out.

I hear ya. Although you should be able to compress a PNG without too much loss of image quality, no? And of course part of the issue is trying to balance these things with keeping the site viable.

In any case, since this isn't a ‘bug’ as such I would recommend moving this over to General Discussion! Here is a thread where people are talking about the new changes: http://www.theduckwebcomics.com/forum/topic/177423/

Or you can feel free to create your own! I'm the only person who looks at this thread with any regularity so you can probably get a better discussion over there.
Duchess of Friday Newsposts and the holy Top Ten
HippieVan at 12:38PM, Feb. 7, 2016
(online)
posts: 3,003
joined: 3-15-2008
Also, I am going to delete some of the replies here that have already been addressed because I really want to keep this thread ‘clean’ so that users can easily find the solution to their problem. It's getting a bit long and messy.

I'm leaving the discussion of image size for now because I don't want those suggestions to be lost, but it's definitely a good idea to go give your two cents in one of the General Discussion threads.
Duchess of Friday Newsposts and the holy Top Ten
Prototype at 1:43PM, Feb. 7, 2016
(online)
posts: 40
joined: 5-23-2008
I hear ya. Although you should be able to compress a PNG without too much loss of image quality, no? And of course part of the issue is trying to balance these things with keeping the site viable.

Hmmm.. compress PNG? That's not any option like that when saving in photoshop. And that kinda goes against the whole point having PNG if I'm to compress it and make it look worse. Then I could just use JPG right away. I understand the reason, but personally I'm not sure forcing users to lessen the quality of their artwork is a good way to go.

Anyway, I posted about this in the other topic. So I'll move the discussion over there.

last edited on Feb. 7, 2016 1:44PM
irrevenant at 8:22PM, Feb. 7, 2016
(online)
posts: 753
joined: 1-13-2007
For reference the other thread Prototype referred to is at http://www.theduckwebcomics.com/forum/topic/177423/

P.S. I believe HippieVan was thinking of JPGs. PNGs do have a compression setting but it's non-lossy - it just affects how CPU-intensive the graphic is to view. With modern technology, there's almost never a reason not to just use the highest compression (smallest filesize) for a PNG.
last edited on Feb. 13, 2016 9:16PM
Hobomatt at 8:03PM, Feb. 12, 2016
(online)
posts: 1
joined: 2-12-2016
I cannot get the correct date on the “when born” part of the registration page.
For the record, it is July 16, 1950 ( not 2003!)
Thanks,
Matt
Hobomatt
HippieVan at 12:34PM, Feb. 13, 2016
(online)
posts: 3,003
joined: 3-15-2008
irrevenant wrote:
For reference the other type Prototype referred to is at http://www.theduckwebcomics.com/forum/topic/177423/

P.S. I believe HippieVan was thinking of JPGs. PNGs do have a compression setting but it's non-lossy - it just affects how CPU-intensive the graphic is to view. With modern technology, there's almost never a reason not to just use the highest compression (smallest filesize) for a PNG.

Nah it was just me being dumb, thanks though haha. For whatever reason my version of photoshop has always been a bit persnickety about PNGs so I'm not too familiar with their limitations. (Fortunately I'm not the only one who makes decisions around here!)
Duchess of Friday Newsposts and the holy Top Ten
HippieVan at 12:36PM, Feb. 13, 2016
(online)
posts: 3,003
joined: 3-15-2008
Hobomatt wrote:
I cannot get the correct date on the “when born” part of the registration page.
For the record, it is July 16, 1950 ( not 2003!)
Thanks,
Matt
Hobomatt

I went ahead and changed it for you! You should be able to access everything now, but let me know if you're having any issues.
Duchess of Friday Newsposts and the holy Top Ten
Darwin at 7:22AM, Feb. 14, 2016
(online)
posts: 619
joined: 4-25-2006
I know this bug is listed, but I wanted to make an addendum to what you have in the first listing.

Initially upon resurrecting my Plague site, I uploaded the links I wanted into the system and then used the image locker to copy/paste the navigation links I wanted on the pages. And initially it worked (it had the Amazon precursor information on the link), all of the buttons appeared and it was navigable.

However later that afternoon the links were broken and not visible. Despite several tries at resetting the image link from the locker, they would not show up.

I've had to fall back on using links from my main site's host, but it seemed a lot of work for nothing to have the links break after they initially worked.
HippieVan at 9:16AM, Feb. 14, 2016
(online)
posts: 3,003
joined: 3-15-2008
Darwin wrote:
I know this bug is listed, but I wanted to make an addendum to what you have in the first listing.

Initially upon resurrecting my Plague site, I uploaded the links I wanted into the system and then used the image locker to copy/paste the navigation links I wanted on the pages. And initially it worked (it had the Amazon precursor information on the link), all of the buttons appeared and it was navigable.

However later that afternoon the links were broken and not visible. Despite several tries at resetting the image link from the locker, they would not show up.

I've had to fall back on using links from my main site's host, but it seemed a lot of work for nothing to have the links break after they initially worked.

Hmm, that's really strange! And I definitely feel your frustration. When did this happen?

If you pass on the original image links to me I can play around with it and see if I can get them to work.
Duchess of Friday Newsposts and the holy Top Ten
HippieVan at 5:44PM, Feb. 14, 2016
(online)
posts: 3,003
joined: 3-15-2008
The “expires” in the code rather worries me…

Oh and if I open the link to look at the images directly they appear fine. Dunno if that will help with troubleshooting or not.

Oh, I know what the issue is. You have to delete all that crap after the “.png” portion so that instead of looking like this:

http://s3.amazonaws.com/media.drunkduck.com/users/Darwin/assets/dd-prev.png?Signature=H10%2B7XuqjeJl1ztQsWL25dZUAk8%3D&Expires=1455500173&AWSAccessKeyId=AKIAJNTWODVRHV3VHO4A

it looks like this:

http://s3.amazonaws.com/media.drunkduck.com/users/Darwin/assets/dd-prev.png

It's really stupid and I don't know why it adds all that garbage at the end of the link, but it's in my list of things that need to be fixed.

In the meantime, I changed your links and they all appear to be working now, so hooray! But let me know if you have any more issues with them.

Edited to add: I've added this advice to the top post, so hopefully that will be helpful to other people with the same problem in the future.
Duchess of Friday Newsposts and the holy Top Ten
last edited on Feb. 14, 2016 5:48PM
waffleman113 at 1:20PM, Feb. 20, 2016
(online)
posts: 2
joined: 2-20-2016
How do you change the title of a comic? When I was making a comic I made just a page named after its entire title.
HippieVan at 2:31PM, Feb. 20, 2016
(online)
posts: 3,003
joined: 3-15-2008
waffleman113 wrote:
How do you change the title of a comic? When I was making a comic I made just a page named after its entire title.

I'm not sure I understand the issue. You want to change the name of your comic? Unfortunately once you've named your comic you're stuck with that name, but I can change it for you if it's absolutely necessary. Since you've only uploaded one page and you don't have a custom layout or anything yet, it might make more sense to delete your comic and start a new one with the correct name.
Duchess of Friday Newsposts and the holy Top Ten
Sway at 9:40PM, March 7, 2016
(online)
posts: 31
joined: 1-29-2015
So apparently around half of my readers can't see my most recent update. I didn't do anything different from what I normally do (didn't save it differently or in a different format). Are there any known issues that would prevent a page from being visible to all readers? Again, it seems to be about 50/50. Some can see it, some can't.
HippieVan at 10:39AM, March 8, 2016
(online)
posts: 3,003
joined: 3-15-2008
Sway wrote:
So apparently around half of my readers can't see my most recent update. I didn't do anything different from what I normally do (didn't save it differently or in a different format). Are there any known issues that would prevent a page from being visible to all readers? Again, it seems to be about 50/50. Some can see it, some can't.

That is really strange, and not a bug we've had reported yet as far as I know. I know this is tricky because your it's your readers and not you experiencing the issue, but any other info you can provide would be helpful. What browsers are people using? Operating systems? Are they seeing a dead image link, nothing at all, etc.?
Duchess of Friday Newsposts and the holy Top Ten
Sway at 2:50PM, March 8, 2016
(online)
posts: 31
joined: 1-29-2015
According to Falopiancrusader it's showing up in Firefox, but not Chrome. I can confirm that it's showing up in Safari on both mobile and desktop iOS.
HippieVan at 4:42PM, March 8, 2016
(online)
posts: 3,003
joined: 3-15-2008
Sway wrote:
According to Falopiancrusader it's showing up in Firefox, but not Chrome. I can confirm that it's showing up in Safari on both mobile and desktop iOS.

Aha! I may have figured out the issue. I also use Chrome and it was showing up for me so I was puzzled at first, but then I turned on adblock just as an experiment and it disappeared. I'm just throwing this out there, but is it possible that because you have the page labelled “ADVERTISEMENT,” that adblock is mistakenly identifying it as an ad?

If that is the problem, I guess your solutions would be either to change the name of the page and see if that fixes it (and possibly the file name too, depending on what it is?), or to advise your readers to turn off adblock for the site (we only use PW ads these days, so they shouldn't be too annoying (and they do fund the site, after all)).

Let me know if any of that works!
Duchess of Friday Newsposts and the holy Top Ten
Sway at 5:28PM, March 8, 2016
(online)
posts: 31
joined: 1-29-2015
That's hilarious. I'll definitely give it a try!
mashumatt at 10:46AM, April 11, 2016
(online)
posts: 1
joined: 4-10-2016
I am trying to upload a page from my comic strip (a JPEG image which is about 102KB) but nothing happens when I click on ‘save page’. Can anyone please help?

Forgot Password
©2011 WOWIO, Inc. All Rights Reserved Google+